Tutorial update ip public di tunnelbroker dari scripting mikrotik bagi pengguna Telkom IndiHome

Hai di sini NATANETWORK mau berbagi tutorial sederhana bagaimana kamu bisa melakukan update ip public telkom IndiHome yang berubah-ubah jika di restart modem nya kedalam tunnelbroker. Sebelumnya buat kamu yang belum mengetahui cara menggunakan tunnelbroker dan fungsinya, silahkan baca halaman ini terlebih dahulu https://www.natanetwork.com/portal/knowledgebase/220/Akses-website-IPv6-menggunakan-Tunnelbroker.html

Pengguna internet Telkom IndiHome dengan router mikrotik, terdapat 2 cara yaitu :

  1. account Indihome PPOE di dial dari router mikrotik itu sendiri, sehingga ip public dynamic akan menempel di perangkat router mikrotik kamu.
  2. account IndiHome di dial dari modem itu sendiri, dan kamu melanjutkan koneksi tersebut kedalam router mikrotik, metode ini dikenal sebagai behind ip public / NAT.

Dalam kasus ini, kami menggunakan metode no 2 dan akan menunjukan tutorial untuk melakukan update ip public yang berubah-ubah dengan menggunakan scripting dari mikrotik dan memanfaatkan API dari tunnelbroker itu sendiri.

Langkah yang bisa diambil adalah :

  1. Pastikan kamu punya account ke tunnelnbroker.net dan masuk kedalam menu Advance


    simpan update URL tersebut untuk keperluan dimasukan kedalam scripting mikrotik.

  2. Buka router mikrotik kamu menggunakan winbox terbaru
  3. Buat script baru di menu system --> scripts
  4. Masukan script seperti contoh dibawah ini dengan nama script tunnelbroker:

    :global WANIP
    :local cloudStatus [/ip cloud get status]
    :local currentWANIP $WANIP
    :if ($cloudStatus = "updated") do={ :set currentWANIP [/ip cloud get public-address] }

    :if ($currentWANIP != $WANIP) do={
    /tool fetch src-address=<isi ip private mikrotik> keep-result=no \
    url="https://natanetwork:xxxxxxx@ipv4.tunnelbroker.net/nic/update\3Fhostname=xxxxx"

    :set WANIP $currentWANIP
    :log info "Updated TunnelBroker EndPoint - $currentWANIP"
    }

    Pastikan kamu mengubah script yang berwarna merah, src-address di isi dengan ip private yang digunakan oleh mikrotik (router is behind a NAT) dan URL di isikan dengan Update URL yang kamu dapatkan di website tunnelbroker.net

  5. Pastikan fitur cloud telah aktif
    Masuk ke menu IP --> Cloud 
    Centang DDNS Enabled dan Update Time



  6. Masuk menu System --> Scheduler dan buat schedule baru dengan nama tunnelbroker


    Sesuaikan seperti contoh diatas ini. Schedule script ini akan running setiap 1 menit sekali untuk melakukan pengecekan apakah ip public IndiHome berubah atau masi tetap yang lama.

 

 

Kesimpulan

Dari sini kami bisa simpulkan tidak perlu kamu menggunakan ip public statik untuk memanfaatkan ipv6 dari tunnelbroker, dengan ip public dynamic by IndiHome dan sedikit modifikasi scripting mikrotik, maka kamu juga akan secara otomatis dapat menikmati layanan ipv6 dari tunnelbroker tanpa repot-repot untuk mengganti ip public jika terjadi perubahan terus menerus. Logika dari scripting tersebut adalah melakukan update ip pada website tunnelbroker jika ip public IndiHome kita berubah, di buatnya script untuk melakukan pengecekan setiap satu menit secara terus menerus.

Terimakasih telah menyimak tutorial ini, semoga bermanfaat !

 

 

  • tunnelbroker, script mikrotik, menggunakan ipv6 tunnelbroker mikrotik
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

Setup Mikrotik OS pada VPS IIX/USA milik Natanetwork

halo pelanggan setia,untuk dapat menggunakan mikrotik OS pastikan anda order paket VPS...

License Mikrotik CHR OS 6

Hisecara default mikrotik CHR ini hanya mendapatkan free license 1mbps max speed.jika kalian...

Backup mikrotik configuration ke email gmail

untuk melakukan backup mikrotik, silahkan gunakan script backup yang dapat di running setiap...

Setting Port Forward pada Mikrotik

Dalam kasus ini jika kalian memiliki ip public yang bisa digunakan untuk remote routeboard, anda...

Blokir port email untuk menghindari ip blacklist (spam) pada mikrotik

Terkadang cloud mikrotik yang kita gunakan untuk ip public nya bisa terdeteksi spam atau ip...

Powered by WHMCompleteSolution